acegi-security-1.0.7-2.jpp5.noarch.rpm


Advertisement

Description

acegi-security - ACEGI spring security

Property Value
Distribution RPM Universal
Repository JPackage 5.0 all
Package name acegi-security
Package version 1.0.7
Package release 2.jpp5
Package architecture noarch
Package type rpm
Installed size 568.22 KB
Download size 488.04 KB
Official Mirror mirrors.dotsrc.org
Acegi Security is an open source project that provides
comprehensive authentication and authorisation services for
enterprise applications based on The Spring Framework. Acegi
Security can authenticate using a variety of pluggable
providers, and can authorise both web requests and method
invocations. Acegi Security provides an integrated security
approach across these various targets, and also offers
access control list (ACL) capabilities to enable individual
domain object instances to be secured. At an implementation
level, Acegi Security is managed through Spring's inversion
of control and lifecycle services, and actually enforces
security using interception through servlet Filters and Java
AOP frameworks. In terms of AOP framework support, Acegi
Security currently supports AOP Alliance (which is what the
Spring IoC container uses internally) and AspectJ, although
additional frameworks can be easily supported.

Alternatives

Package Version Architecture Repository
acegi-security-1.0.7-3.jpp6.noarch.rpm 1.0.7 noarch JPackage 6.0
acegi-security - - -

Requires

Name Value
ehcache -
jakarta-taglibs-standard -
java >= 1.5.0
jpackage-utils >= 1.7.5
slf4j -
spring-aop -
spring-core -
spring-jdbc -
spring-mock -
spring-remoting -
spring-web -

Provides

Name Value
acegi-security = 1.0.7-2.jpp5

Download

Type URL
Binary Package acegi-security-1.0.7-2.jpp5.noarch.rpm
Source Package acegi-security-1.0.7-2.jpp5.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Download the latest jpackage-release rpm from
    http://mirrors.dotsrc.org/jpackage/5.0/generic/free/RPMS/
  2. Install jpackage-release rpm:
    # rpm -Uvh jpackage-release*rpm
  3. Install acegi-security rpm package:
    # yum install acegi-security
openSUSE:
  1. Add the JPackage 5.0 repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ jpackage-5.0
  2. Install acegi-security rpm package:
    # zypper install acegi-security
Mandriva, Mageia:
  1. Add the JPackage 5.0 repository:
    # urpmi.addmedia jpackage-5.0 http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install acegi-security rpm package:
    # urpmi acegi-security

Files

Path
/etc/maven/fragments/acegi-security
/usr/share/java/acegi-security/core-1.0.7.jar
/usr/share/java/acegi-security/core.jar
/usr/share/java/acegi-security/tiger-1.0.7.jar
/usr/share/java/acegi-security/tiger.jar
/usr/share/maven2/poms/JPP.acegi-security-adapters.pom
/usr/share/maven2/poms/JPP.acegi-security-catalina.pom
/usr/share/maven2/poms/JPP.acegi-security-core.pom
/usr/share/maven2/poms/JPP.acegi-security-jboss.pom
/usr/share/maven2/poms/JPP.acegi-security-parent.pom
/usr/share/maven2/poms/JPP.acegi-security-tiger.pom

Changelog

2009-01-19 - Ralph Apel <r.apel at r-apel.de> 0:1.0.7-2.jpp5
- BR tomcat5 instead of tomcat5-server-lib: poms
2008-07-16 - Ralph Apel <r.apel at r-apel.de> 0:1.0.7-1.jpp5
- Initial release

See Also

Package Description
acegi-security-adapter-catalina-1.0.7-2.jpp5.noarch.rpm Catalina adapter for acegi-security
acegi-security-adapter-jboss-1.0.7-2.jpp5.noarch.rpm JBoss adapter for acegi-security
acegi-security-javadoc-1.0.7-2.jpp5.noarch.rpm Javadoc for acegi-security
activeio3-3.0.1-1.jpp5.noarch.rpm ActiveIO Protocol Implementation Framework
activeio3-javadoc-3.0.1-1.jpp5.noarch.rpm Javadoc for activeio3
activemq4-4.1.2-1.jpp5.noarch.rpm ActiveMQ Message Broker
activemq4-all-4.1.2-1.jpp5.noarch.rpm All of activemq4
activemq4-console-4.1.2-1.jpp5.noarch.rpm Console from activemq4
activemq4-jaas-4.1.2-1.jpp5.noarch.rpm JAAS from activemq4
activemq4-javadoc-4.1.2-1.jpp5.noarch.rpm Javadoc for activemq4
activemq4-maven-plugins-4.1.2-1.jpp5.noarch.rpm Maven2 Plugins from activemq4
activemq4-openwire-generator-4.1.2-1.jpp5.noarch.rpm Openwire Generator from activemq4
activemq4-optional-4.1.2-1.jpp5.noarch.rpm Optional from activemq4
activemq4-ra-4.1.2-1.jpp5.noarch.rpm Resource Adapter from activemq4
activemq4-web-4.1.2-1.jpp5.noarch.rpm Web Module from activemq4
Advertisement
Advertisement