bouncycastle-1.43-1.jpp5.noarch.rpm


Advertisement

Description

bouncycastle - Bouncy Castle Crypto Package for Java

Distribution: RPM Universal
Repository: JPackage 5.0 all
Package name: bouncycastle
Package version: 1.43
Package release: 1.jpp5
Package architecture: noarch
Package type: rpm
Installed size: 3.66 MB
Download size: 3.11 MB
Official Mirror: mirrors.dotsrc.org
The Bouncy Castle Crypto APIs for Java consist of the following: * A lightweight cryptography API for Java. * A provider for the Java Cryptography Extension and the Java Cryptography Architecture. * A clean room implementation of the JCE 1.2.1. * A library for reading and writing encoded ASN.1 objects. * A light weight client-side TLS API. * Generators for Version 1 and Version 3 X.509 certificates, Version 2 CRLs, and PKCS12 files. * Generators for Version 2 X.509 attribute certificates. * Generators/Processors for S/MIME and CMS (PKCS7/RFC 3852). * Generators/Processors for OCSP (RFC 2560). * Generators/Processors for TSP (RFC 3161). * Generators/Processors for OpenPGP (RFC 2440). * A signed jar version suitable for JDK 1.5 and the Sun JCE. The lightweight API works with everything from the J2ME to the JDK 1.6.

Alternatives

Provides

  • bouncycastle = 1.43-1.jpp5
  • bouncycastle-provider = 1.43-1.jpp5
  • jce = 1.5.0.0

Obsoletes

  • bouncycastle-jdk1.4 < 1.43-1.jpp5
  • bouncycastle-jdk1.5 < 1.43-1.jpp5
  • bouncycastle-jdk1.6 < 1.43-1.jpp5
  • bouncycastle-provider < 1.43-1.jpp5

    Install Howto

    Fedora, CentOS, RHEL:
    1. Download the latest jpackage-release rpm from
      http://mirrors.dotsrc.org/jpackage/5.0/generic/free/RPMS/
    2. Install jpackage-release rpm:
      # rpm -Uvh jpackage-release*rpm
    3. Install bouncycastle rpm package:
      # yum install bouncycastle
    openSUSE:
    1. Add the JPackage 5.0 repository:
      # zypper addrepo http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ jpackage-5.0
    2. Install bouncycastle rpm package:
      # zypper install bouncycastle
    Mandriva, Mageia:
    1. Add the JPackage 5.0 repository:
      # urpmi.addmedia jpackage-5.0 http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ with hdlist.cz
    2. Update packages list:
      # urpmi.update -a
    3. Install bouncycastle rpm package:
      # urpmi bouncycastle

    Files

    • /usr/share/doc/bouncycastle-1.43/CONTRIBUTORS.html
    • /usr/share/doc/bouncycastle-1.43/LICENSE.html
    • /usr/share/doc/bouncycastle-1.43/index.html
    • /usr/share/doc/bouncycastle-1.43/releasenotes.html
    • /usr/share/doc/bouncycastle-1.43/specifications.html
    • /usr/share/java/bcmail-1.43.jar
    • /usr/share/java/bcmail.jar
    • /usr/share/java/bcpg-1.43.jar
    • /usr/share/java/bcpg.jar
    • /usr/share/java/bcprov-1.43.jar
    • /usr/share/java/bcprov.jar
    • /usr/share/java/bctest-1.43.jar
    • /usr/share/java/bctest.jar
    • /usr/share/java/bctsp-1.43.jar
    • /usr/share/java/bctsp.jar

    Changelog

    2009-04-20 - David Walluck <dwalluck@redhat.com> 0:1.43-1 - 1.43

    2009-03-20 - David Walluck <dwalluck@redhat.com> 0:1.42-3 - package using the upstream signed jars by default

    2009-03-17 - David Walluck <dwalluck@redhat.com> 0:1.42-2 - add support for upstream-signed jar - update URL and description

    2009-03-16 - David Walluck <dwalluck@redhat.com> 0:1.42-1 - 1.42 - add support for jdk5

    2008-12-08 - Will Tatam <will.tatam@red61.com> 0:1.41-2 - Auto rebuild for JPackage 5 in mock

    2008-11-13 - David Walluck <dwalluck@redhat.com> 0:1.41-1 - 1.41 - require javamail 1.4

    2007-11-01 - Ralph Apel <r.apel at r-apel.de> 0:1.37-5jpp - Bump release

    2007-10-31 - Ralph Apel <r.apel at r-apel.de> 0:1.37-4jpp - Explicitly Require bouncycastle-jdk1.5 in main package

    2007-10-30 - Ralph Apel <r.apel at r-apel.de> 0:1.37-3jpp - Build jdk1.4 thru jdk1.6 packages for JPP-5.0

    2007-10-30 - Ralph Apel <r.apel at r-apel.de> 0:1.37-2jpp - Build jdk1.4 packages for JPP-1.7

    Advertisement
    Advertisement