ivy-1.3.1-3.jpp5.noarch.rpm


Advertisement

Description

ivy - Dependency manager

Distribution: RPM Universal
Repository: JPackage 5.0 all
Package name: ivy
Package version: 1.3.1
Package release: 3.jpp5
Package architecture: noarch
Package type: rpm
Installed size: 360.17 KB
Download size: 336.37 KB
Official Mirror: mirrors.dotsrc.org
Ivy is a free java based dependency manager, with powerful features such as transitive dependencies, ant integration, maven repository compatibility, continuous integration, html reports and many more.

Alternatives

Provides

  • ivy = 1.3.1-3.jpp5

    Download

    Source package: ivy-1.3.1-3.jpp5.src.rpm

    Install Howto

    Fedora, CentOS, RHEL:
    1. Download the latest jpackage-release rpm from
      http://mirrors.dotsrc.org/jpackage/5.0/generic/free/RPMS/
    2. Install jpackage-release rpm:
      # rpm -Uvh jpackage-release*rpm
    3. Install ivy rpm package:
      # yum install ivy
    openSUSE:
    1. Add the JPackage 5.0 repository:
      # zypper addrepo http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ jpackage-5.0
    2. Install ivy rpm package:
      # zypper install ivy
    Mandriva, Mageia:
    1. Add the JPackage 5.0 repository:
      # urpmi.addmedia jpackage-5.0 http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ with hdlist.cz
    2. Update packages list:
      # urpmi.update -a
    3. Install ivy rpm package:
      # urpmi ivy

    Files

    • /etc/maven/fragments/ivy
    • /usr/share/ivy-1.3.1/LICENSE.txt
    • /usr/share/java/ivy-1.3.1.jar
    • /usr/share/java/ivy.jar
    • /usr/share/maven2/poms/JPP-ivy.pom

    Changelog

    2008-07-06 - Ralph Apel <r.apel at r-apel.de> - 0:1.3.1-3.jpp5 - Add depmap frag with jayasoft as groudId

    2008-07-05 - Ralph Apel <r.apel at r-apel.de> - 0:1.3.1-2.jpp5 - Import to cvs - Add pom and depmap frag

    2006-04-05 - Ralph Apel <r.apel at r-apel.de> - 0:1.3.1-1jpp - Upgrade to 1.3.1 final and adapt to j-c-httpclient = 3.0 final

    2006-02-22 - Ralph Apel <r.apel at r-apel.de> - 0:1.3-0.rc2.2jpp - Patch to build/run with java-1.4.2-bea (doesn't tolerate double slash in path)

    2006-02-17 - Ralph Apel <r.apel at r-apel.de> - 0:1.3-0.rc2.1jpp - First JPackage release

    Advertisement
    Advertisement