saxon8-B.8.7-2.jpp5.noarch.rpm


Advertisement

Description

saxon8 - Java Basic XPath 2.0, XSLT 2.0, and XQuery 1.0 implementation

Property Value
Distribution RPM Universal
Repository JPackage 5.0 all
Package name saxon8
Package version B.8.7
Package release 2.jpp5
Package architecture noarch
Package type rpm
Installed size 1.36 MB
Download size 1.27 MB
Official Mirror mirrors.dotsrc.org
Release 8.6 represents an important milestone in Saxonica's
progressive implementation of the XPath 2.0, XSLT 2.0, and
XQuery 1.0 specifications. Saxon 8.6 is aligned with the W3C
Candidate Recommendation published on 3 November 2005. It is
a complete and conformant implementation, providing all the
mandatory features of those specifications and nearly all the
optional features.
Saxon is available in two versions. Saxon-B is a non-schema-aware
processor, and is available as an open-source product, free of
charge, from SourceForge. It is designed to conform to the basic
conformance level of XSLT 2.0, and the equivalent level of
functionality in XQuery 1.0. Saxon-SA is the schema-aware version
of the package, and is available as a commercially supported
product from Saxonica Limited.
This package provides the Basic XSLT 2.0 and XQuery 1.0 processor.
Includes the command line interfaces and the JAVA APIs; also
includes a standalone XPath API that doesn't depend on JAXP 1.3.

Alternatives

Package Version Architecture Repository
saxon8-B.8.7-4.jpp6.noarch.rpm B.8.7 noarch JPackage 6.0
saxon8 - - -

Requires

Name Value
/usr/sbin/update-alternatives -
bea-stax -
bea-stax-api -
jaxp_parser_impl -

Provides

Name Value
jaxp_transform_impl -
saxon8 = B.8.7-2.jpp5

Download

Type URL
Binary Package saxon8-B.8.7-2.jpp5.noarch.rpm
Source Package saxon8-B.8.7-2.jpp5.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Download the latest jpackage-release rpm from
    http://mirrors.dotsrc.org/jpackage/5.0/generic/free/RPMS/
  2. Install jpackage-release rpm:
    # rpm -Uvh jpackage-release*rpm
  3. Install saxon8 rpm package:
    # yum install saxon8
openSUSE:
  1. Add the JPackage 5.0 repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ jpackage-5.0
  2. Install saxon8 rpm package:
    # zypper install saxon8
Mandriva, Mageia:
  1. Add the JPackage 5.0 repository:
    # urpmi.addmedia jpackage-5.0 http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install saxon8 rpm package:
    # urpmi saxon8

Files

Path
/usr/share/java/jaxp_transform_impl.jar
/usr/share/java/saxon8-B.8.7.jar
/usr/share/java/saxon8.jar

Changelog

2008-10-03 - David Walluck <dwalluck@redhat.com> 0:B.8.7-2
- add GCJ support
- add optional XOM support
2006-03-14 - Deepak Bhole <dbhole@redhat.com> - 0:B.8.7-1jpp
- Changed package name for compatibility
- Upgraded to 8.7
- Added saxonq script for queries
- Updated man pages
2006-01-30 - Ralph Apel <r.apel@r-apel.de> - 0:8.6.1-1jpp
- Derive saxonb8 from saxon7
2005-09-05 - Ralph Apel <r.apel@r-apel.de> - 0:7.9.1-1jpp
- Derive saxon7 from saxon
- no more aelfred nor fop subpackages
2004-09-03 - Fernando Nasser <fnasser@redhat.com> - 0:6.5.3-3jpp
- Rebuilt with Ant 1.6.2
2004-07-19 - Ville Skyttä <ville.skytta at iki.fi> - 0:6.5.3-2jpp
- Apply two patches for known limitations from
http://saxon.sourceforge.net/saxon6.5.3/limitations.html
- Make the command line script use xml-commons-resolver if it's available.
- Include man page for command line script.
- Add patch to fix command line option handling and document missing options.
- New style versionless javadoc dir symlinking.
- Crosslink with local J2SE javadocs.
- Add missing jdom-javadoc build dependency.
2003-08-31 - Ville Skyttä <ville.skytta at iki.fi> - 0:6.5.3-1jpp
- Update to 6.5.3.
- Crosslink with local xml-commons-apis and fop javadocs.
2003-06-03 - Ville Skyttä <ville.skytta at iki.fi> - 0:6.5.2-7jpp
- Non-versioned javadoc symlinking.
- Include Main-Class attribute in saxon.jar.
- Own (ghost) %{_javadir}/jaxp_transform_impl.jar.
- Remove alternatives in preun instead of postun.
2003-04-17 - Ville Skyttä <ville.skytta at iki.fi> - 6.5.2-6jpp
- Rebuild for JPackage 1.5.
- Split shell script to -scripts subpackage.
- Use non-versioned jar in jaxp_transform_impl alternative, and don't remove
it on upgrade.
- Spec file cleanups.
2002-07-25 - Ville Skyttä <ville.skytta at iki.fi> 6.5.2-5jpp
- Fix shell script (again).
- Rebuild with -Dbuild.compiler=modern (saxon-fop won't build with jikes).

See Also

Package Description
saxon8-demo-B.8.7-2.jpp5.noarch.rpm Demos for saxon8
saxon8-dom-B.8.7-2.jpp5.noarch.rpm DOM support for saxon8
saxon8-javadoc-B.8.7-2.jpp5.noarch.rpm Javadoc for saxon8
saxon8-jdom-B.8.7-2.jpp5.noarch.rpm JDOM support for saxon8
saxon8-manual-B.8.7-2.jpp5.noarch.rpm Manual for saxon8
saxon8-scripts-B.8.7-2.jpp5.noarch.rpm Utility scripts for saxon8
saxon8-sql-B.8.7-2.jpp5.noarch.rpm SQL support for saxon8
saxon8-xom-B.8.7-2.jpp5.noarch.rpm XOM support for saxon8
saxon8-xpath-B.8.7-2.jpp5.noarch.rpm XPATH support for saxon8
saxpath-1.0-3.jpp5.noarch.rpm Java XPath engine for use on a variety of XML object models
saxpath-javadoc-1.0-3.jpp5.noarch.rpm Javadoc for saxpath
serp-1.13.1-1jpp.noarch.rpm Bytecode manipulation framework
serp-javadoc-1.13.1-1jpp.noarch.rpm Javadoc for serp
serp-manual-1.13.1-1jpp.noarch.rpm Documents for serp
servletapi4-4.0.4-6.jpp5.noarch.rpm Java Servlet 2.3 and JSP 1.2 API classes
Advertisement
Advertisement