tomcat5-jasper-eclipse-5.5.27-7.jpp5.noarch.rpm


Advertisement

Description

tomcat5-jasper-eclipse - Jasper OSGi Eclipse plugin

Property Value
Distribution RPM Universal
Repository JPackage 5.0 all
Package filename tomcat5-jasper-eclipse-5.5.27-7.jpp5.noarch.rpm
Package name tomcat5-jasper-eclipse
Package version 5.5.27
Package release 7.jpp5
Package architecture noarch
Package type rpm
Homepage -
License -
Maintainer -
Download size 1.71 MB
Installed size 1.77 MB
Jasper OSGi Eclipse plugin that contains class files from jasper-compiler,
jasper-runtime and ECJ.

Alternatives

Package Version Architecture Repository
tomcat5-jasper-eclipse-5.5.35-1.jpp6.noarch.rpm 5.5.35 noarch JPackage 6.0
tomcat5-jasper-eclipse - - -

Provides

Name Value
tomcat5-jasper-eclipse = 5.5.27-7.jpp5

Download

Type URL
Mirror mirrors.dotsrc.org
Binary Package tomcat5-jasper-eclipse-5.5.27-7.jpp5.noarch.rpm
Source Package tomcat5-5.5.27-7.jpp5.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Download latest jpackage-release rpm from
    http://mirrors.dotsrc.org/jpackage/5.0/generic/free/RPMS/
  2. Install jpackage-release rpm:
    # rpm -Uvh jpackage-release*rpm
  3. Install tomcat5-jasper-eclipse rpm package:
    # yum install tomcat5-jasper-eclipse
openSUSE:
  1. Add the JPackage 5.0 repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ jpackage-5.0
  2. Install tomcat5-jasper-eclipse rpm package:
    # zypper install tomcat5-jasper-eclipse
Mandriva, Mageia:
  1. Add the JPackage 5.0 repository:
    # urpmi.addmedia jpackage-5.0 http://mirrors.dotsrc.org/jpackage/5.0/generic/free/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install tomcat5-jasper-eclipse rpm package:
    # urpmi tomcat5-jasper-eclipse

Files

Path
/usr/share/eclipse/
/usr/share/eclipse/plugins/org.apache.jasper_5.5.17.v200706111724.jar

Changelog

2008-12-11 - David Walluck <dwalluck@redhat.com> 0:5.5.27-7
- fix pom file permissions
2008-12-04 - David Walluck <dwalluck@redhat.com> 0:5.5.27-6
- sync up epochs and versions for BuildRequires
- add Requires on jaf and javamail
- add (Build)Requires on stuts and struts-taglib 1.3.8
- remove locale attribute from jsp files for new struts
- use BuildRequires jaf_1_0_2_api instead of jaf
- make jsp package require its own servlet package instead of servlet24
- add Requires(post) for jakarta-commons-daemon and jakarta-commons-logging
- fix some missing logic in initscript
2008-12-02 - David Walluck <dwalluck@redhat.com> 0:5.5.27-5
- rediff patches
2008-10-07 - David Walluck <dwalluck@redhat.com> 0:5.5.27-4
- add changes for OSGi
- use %{_sbindir}
- redefine %{_initrddir} to be LSB-compliant
- make initscript LSB-complaint
- lower jakarta-commons-io requirement for Fedora
2008-09-26 - David Walluck <dwalluck@redhat.com> 0:5.5.27-3
- fix status in initscript
2008-09-25 - David Walluck <dwalluck@redhat.com> 0:5.5.27-2
- add patch for unversioned commons-logging.jar
- don't create backup files for patches
2008-09-15 - David Walluck <dwalluck@redhat.com> 0:5.5.27-1
- 5.5.27
- properly unpack sources
- allow java-devel > 1.5
- fix javadocs
- use more strict permissions
- fix maven file ownership
- fix GCJ support
2008-06-26 - Ralph Apel <r.apel at r-apel.de> 0:5.5.26-3.jpp5
- Add tomcat-parent pom and depmap frag
2008-06-19 - Ralph Apel <r.apel at r-apel.de> 0:5.5.26-2.jpp5
- Require ecj in main package also
- Explicitly drop 3 jars from bindir, may be old files or new symlinks
2008-06-05 - Ralph Apel <r.apel at r-apel.de> 0:5.5.26-1jpp
- 5.5.26
- Build with java5 for java5
- Add poms and depmap frags
- Move touch and chown of TOMCAT_LOG __after__ possible makeHomeDir
in init script
- Temporarily set umask to 022 in makeHomeDir
- (Build)Require ecj >= 0:3.3.1.1
- Add catalina-deployer.jar to -server-lib
- Move tomcat-juli.jar from /usr/share/tomcat5/bin/ to 
versioned/unversioned in /usr/share/java/tomcat5/ with 
unversioned symlink where it was
- Replace files commons-daemon.jar and commons-logging-api.jar
in /usr/share/tomcat5/bin/ with symlinks
- Drop dereferencing option on copy of /var/lib/tomcat5
- Switch to standard api (B)Rs and alternatives

See Also

Package Description
tomcat5-jasper-javadoc-5.5.27-7.jpp5.noarch.rpm Javadoc generated documentation for tomcat5-jasper
tomcat5-jsp-2.0-api-5.5.27-7.jpp5.noarch.rpm Apache Tomcat Servlet and JSP implementation classes
tomcat5-jsp-2.0-api-javadoc-5.5.27-7.jpp5.noarch.rpm Javadoc generated documentation for tomcat5-jsp-2.0-api
tomcat5-server-lib-5.5.27-7.jpp5.noarch.rpm Libraries needed to run the Tomcat Web container (part)
tomcat5-servlet-2.4-api-5.5.27-7.jpp5.noarch.rpm Apache Tomcat Servlet implementation classes
tomcat5-servlet-2.4-api-javadoc-5.5.27-7.jpp5.noarch.rpm Javadoc generated documentation for tomcat5-servlet-2.4-api
tomcat5-webapps-5.5.27-7.jpp5.noarch.rpm Web applications for Apache Tomcat
tomcat6-6.0.18-9.jpp5.noarch.rpm Apache Servlet/JSP Engine, RI for Servlet 2.5/JSP 2.1 API
tomcat6-admin-webapps-6.0.18-9.jpp5.noarch.rpm The host-manager and manager web applications for Apache Tomcat
tomcat6-docs-webapp-6.0.18-9.jpp5.noarch.rpm The docs web application for Apache Tomcat
tomcat6-el-1.0-api-6.0.18-9.jpp5.noarch.rpm Expression Language v1.0 API
tomcat6-javadoc-6.0.18-9.jpp5.noarch.rpm Javadoc generated documentation for Apache Tomcat
tomcat6-jsp-2.1-api-6.0.18-9.jpp5.noarch.rpm Apache Tomcat JSP API implementation classes
tomcat6-lib-6.0.18-9.jpp5.noarch.rpm Libraries needed to run the Tomcat Web container
tomcat6-servlet-2.5-api-6.0.18-9.jpp5.noarch.rpm Apache Tomcat Servlet API implementation classes
Advertisement
Advertisement