activesoap-1.0-3.jpp6.noarch.rpm


Advertisement

Description

activesoap - A high performance, lightweight, StAX based SOAP framework

Property Value
Distribution RPM Universal
Repository JPackage 6.0 Devel all
Package filename activesoap-1.0-3.jpp6.noarch.rpm
Package name activesoap
Package version 1.0
Package release 3.jpp6
Package architecture noarch
Package type rpm
Homepage -
License -
Maintainer -
Download size 110.38 KB
Installed size 122.96 KB
ActiveSOAP is a lightweight & easily embeddable REST and SOAP
stack based on StAX with support for WS-Addressing and WSIF.
ActiveSOAP uses StAX (the Standard API for pull parsing) to
implement the SOAP protocols and then it delegates to plugin
Handler objects for the heavy duty processing of the XML
payloads. This means that you only need to pay for what you
need; use fast pull based event parsing or full data binding
mechanisms like JAXB or XStream or DOMish APIs like XMLBeans
when they make sense.
You can use whatever XML marshalling and/or parsing tool you
like to process different messages or headers. The following
APIs are currently supported
* JAXB
* XMLBeans
* XStream
* StaX, SAX, DOM or TrAX
ActiveSOAP is currently used to provide WS-Notification support
in ServiceMix.
In addition to the core StAX processing of SOAP requests (client
and server side) ActiveSOAP provides support for WS-Addressing
and provides multiple WSIF providers.

Alternatives

Package Version Architecture Repository
activesoap - - -

Requires

Name Value
apache-commons-logging -
axis -
bea-stax-api -
jetty5 -
jms_1_1_api -
servlet_2_3_api -
stax-utils -
ws-wsif -
wsdl4j -
xmlbeans -
xstream -

Provides

Name Value
activesoap = 1.0-3.jpp6

Download

Type URL
Mirror mirrors.dotsrc.org
Binary Package activesoap-1.0-3.jpp6.noarch.rpm
Source Package activesoap-1.0-3.jpp6.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Create the repository config file /etc/yum.repos.d/jpackage-generic-6.0-devel.repo:
    
    [jpackage-generic-6.0-devel]
    name=JPackage (free), generic
    baseurl=http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/
    gpgcheck=1
    gpgkey=http://jpackage.org/jpackage.asc
    enabled=1
    
  2. Install activesoap rpm package:
    # yum install activesoap
openSUSE:
  1. Add the JPackage 6.0 Devel repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/ jpackage-6.0-devel
  2. Install activesoap rpm package:
    # zypper install activesoap
Mandriva, Mageia:
  1. Add the JPackage 6.0 Devel repository:
    # urpmi.addmedia jpackage-6.0-devel http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install activesoap rpm package:
    # urpmi activesoap

Files

Path
/usr/share/doc/activesoap-1.0/LICENSE.txt
/usr/share/java/activesoap-1.0.jar
/usr/share/java/activesoap.jar

Changelog

2011-07-08 - Ralph Apel <r.apel at r-apel.de> 0:1.0-3
- Build with maven2 for JPP-6
2007-05-21 - Ralph Apel <r.apel at r-apel.de> 0:1.0-2jpp
- Fix project.xml syntax
- Improve description
- Make Vendor, Distribution based on macro
- Fix aot build
2006-10-17 - Ralph Apel <r.apel at r-apel.de> 0:1.0-1jpp
- First release
- Add gcj_support option
- Add javadoc post/postun Requires

See Also

Package Description
activesoap-javadoc-1.0-3.jpp6.noarch.rpm Javadoc for activesoap
antunit-1.1-1.jpp6.noarch.rpm Ant testing framework
antunit-javadoc-1.1-1.jpp6.noarch.rpm Javadoc for antunit
apache-camel-amqp-2.5.0-4.jpp6.noarch.rpm AMQP component from apache-camel
apache-camel-atom-2.5.0-4.jpp6.noarch.rpm Atom component from apache-camel
apache-camel-bam-2.5.0-4.jpp6.noarch.rpm Bam component from apache-camel
apache-camel-bean-validator-2.5.0-4.jpp6.noarch.rpm Bean Validator component from apache-camel
apache-camel-bindy-2.5.0-4.jpp6.noarch.rpm Bindy component from apache-camel
apache-camel-blueprint-2.5.0-4.jpp6.noarch.rpm Blueprint component from apache-camel
apache-camel-cache-2.5.0-4.jpp6.noarch.rpm Cache component from apache-camel
apache-camel-castor-2.5.0-4.jpp6.noarch.rpm Castor component from apache-camel
apache-camel-cometd-2.5.0-4.jpp6.noarch.rpm Cometd component from apache-camel
apache-camel-core-2.5.0-4.jpp6.noarch.rpm Core module from apache-camel
apache-camel-crypto-2.5.0-4.jpp6.noarch.rpm Crypto component from apache-camel
apache-camel-csv-2.5.0-4.jpp6.noarch.rpm CSV component from apache-camel
Advertisement
Advertisement