spring3-jdbc-3.0.5-2.jpp6.noarch.rpm


Advertisement

Description

spring3-jdbc - Spring jdbc

Property Value
Distribution RPM Universal
Repository JPackage 6.0 Devel all
Package filename spring3-jdbc-3.0.5-2.jpp6.noarch.rpm
Package name spring3-jdbc
Package version 3.0.5
Package release 2.jpp6
Package architecture noarch
Package type rpm
Homepage -
License -
Maintainer -
Download size 338.22 KB
Installed size 376.63 KB
Spring jdbc.

Alternatives

Package Version Architecture Repository
spring3-jdbc - - -

Requires

Name Value
apache-commons-logging -
c3p0 -
derby -
h2database -
hsqldb -
jta_1_1_api -
spring3 = 3.0.5-2.jpp6
spring3-beans = 3.0.5-2.jpp6
spring3-context = 3.0.5-2.jpp6
spring3-core = 3.0.5-2.jpp6
spring3-tx = 3.0.5-2.jpp6

Provides

Name Value
spring3-jdbc = 3.0.5-2.jpp6

Download

Type URL
Mirror mirrors.dotsrc.org
Binary Package spring3-jdbc-3.0.5-2.jpp6.noarch.rpm
Source Package spring3-3.0.5-2.jpp6.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Create the repository config file /etc/yum.repos.d/jpackage-generic-6.0-devel.repo:
    
    [jpackage-generic-6.0-devel]
    name=JPackage (free), generic
    baseurl=http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/
    gpgcheck=1
    gpgkey=http://jpackage.org/jpackage.asc
    enabled=1
    
  2. Install spring3-jdbc rpm package:
    # yum install spring3-jdbc
openSUSE:
  1. Add the JPackage 6.0 Devel repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/ jpackage-6.0-devel
  2. Install spring3-jdbc rpm package:
    # zypper install spring3-jdbc
Mandriva, Mageia:
  1. Add the JPackage 6.0 Devel repository:
    # urpmi.addmedia jpackage-6.0-devel http://mirrors.dotsrc.org/jpackage/6.0/generic/devel/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install spring3-jdbc rpm package:
    # urpmi spring3-jdbc

Files

Path
/usr/share/java/spring3/org.springframework.jdbc-3.0.5.jar
/usr/share/java/spring3/org.springframework.jdbc.jar

Changelog

2011-06-30 - Ralph Apel <r.apel@r-apel.de> 0:3.0.5-2
- Have pkgs Require spring3-tx instead of spring3-transaction
2011-06-29 - Ralph Apel <r.apel@r-apel.de> 0:3.0.5-1
- 3.0.5 as spring3
2009-10-12 - David Walluck <dwalluck@redhat.com> 0:2.5.6-6.SEC01
- add all poms to repolib
- keep bundled bundlor jars
- BuildRequires: geronimo-interceptor-3.0-api (part of ejb3)
- BuildRequires: wsdl4j16 instead of wsdl4j
- use bundled activemq3
- use bundled qdox15
- make xmlgraphics optional (use bundled batik, fop, jai)
2009-09-04 - David Walluck <dwalluck@redhat.com> 0:2.5.6-5.SEC01
- fix cglib
2009-07-03 - David Walluck <dwalluck@redhat.com> 0:2.5.6-4.SEC01
- fix persistence links and (Build)Requires
2009-07-01 - David Walluck <dwalluck@redhat.com> 0:2.5.6-3.SEC01
- add repolib
2009-06-02 - David Walluck <dwalluck@redhat.com> 0:2.5.6-2.SEC01.6
- rebuild for older commons-io
2009-06-01 - David Walluck <dwalluck@redhat.com> 0:2.5.6-2.SEC01.5
- use upstream libs except in specific cases
- don't link to (online) javadocs
2009-05-15 - David Walluck <dwalluck@redhat.com> 0:2.5.6-2.SEC01.4
- remove all Requires
2009-05-07 - Martha Benitez <mbenitez@redhat.com> 0:2.5.6-2.SEC01.3
- Move txt files to main pkg from manual pkg.

See Also

Package Description
spring3-jms-3.0.5-2.jpp6.noarch.rpm Spring jms
spring3-manual-3.0.5-2.jpp6.noarch.rpm Documents for spring3
spring3-orm-3.0.5-2.jpp6.noarch.rpm Spring orm
spring3-oxm-3.0.5-2.jpp6.noarch.rpm Spring orm
spring3-test-3.0.5-2.jpp6.noarch.rpm Spring test
spring3-tx-3.0.5-2.jpp6.noarch.rpm Spring transaction
spring3-web-3.0.5-2.jpp6.noarch.rpm Spring web
spring3-web-portlet-3.0.5-2.jpp6.noarch.rpm Spring web-portlet
spring3-web-servlet-3.0.5-2.jpp6.noarch.rpm Spring web-servlet
spring3-web-struts-3.0.5-2.jpp6.noarch.rpm Spring web-struts
springsource-bundlor-1.0.0-1.jpp6.noarch.rpm Spring Bundlor
springsource-bundlor-devel-1.0.0-1.jpp6.noarch.rpm Source jars for springsource-bundlor
springsource-bundlor-javadoc-1.0.0-1.jpp6.noarch.rpm Javadoc for springsource-bundlor
springsource-bundlor-manual-1.0.0-1.jpp6.noarch.rpm Documents for springsource-bundlor
springsource-util-2.0.0-1.jpp6.noarch.rpm Spring Util
Advertisement
Advertisement