groovy17-1.7.10-3.jpp6.noarch.rpm


Advertisement

Description

groovy17 - Groovy scripting language

Property Value
Distribution RPM Universal
Repository JPackage 6.0 all
Package name groovy17
Package version 1.7.10
Package release 3.jpp6
Package architecture noarch
Package type rpm
Installed size 10.28 MB
Download size 9.07 MB
Official Mirror mirrors.dotsrc.org
Groovy is a new agile dynamic language for the JVM
combining lots of great features from languages like
Python, Ruby and Smalltalk and making them available
to the Java developers using a Java-like syntax.
Groovy is designed to help you get things done on the
Java platform in a quicker, more concise and fun way -
bringing the power of Python and Ruby inside the Java
platform.
Groovy can be used as an alternative compiler to javac
to generate standard Java bytecode to be used by any
Java project or it can be used dynamically as an
alternative language such as for scripting Java objects,
templating or writing unit test cases.

Alternatives

Package Version Architecture Repository
groovy17 - - -

Requires

Name Value
ant -
ant-junit -
ant-trax -
antlr -
bsf -
config(groovy17) = 1.7.10-3.jpp6
jakarta-commons-cli -
jakarta-commons-logging -
jarjar -
java >= 1.6.0
jline -
jpackage-utils -
jpackage-utils >= 1.7.3
jsp_2_0_api -
junit -
livetribe-jsr223 -
mx4j -
objectweb-asm -
servlet_2_4_api -
xpp3-minimal -
xstream -

Provides

Name Value
config(groovy17) = 1.7.10-3.jpp6
groovy17 = 1.7.10-3.jpp6

Download

Type URL
Binary Package groovy17-1.7.10-3.jpp6.noarch.rpm
Source Package groovy17-1.7.10-3.jpp6.src.rpm

Install Howto

Fedora, CentOS, RHEL:
  1. Download latest jpackage-release rpm from
    http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/
  2. Install jpackage-release rpm:
    # rpm -Uvh jpackage-release*rpm
  3. Install groovy17 rpm package:
    # yum install groovy17
openSUSE:
  1. Add the JPackage 6.0 repository:
    # zypper addrepo http://mirrors.dotsrc.org/jpackage/6.0/generic/free/ jpackage-6.0
  2. Install groovy17 rpm package:
    # zypper install groovy17
Mandriva, Mageia:
  1. Add the JPackage 6.0 repository:
    # urpmi.addmedia jpackage-6.0 http://mirrors.dotsrc.org/jpackage/6.0/generic/free/ with hdlist.cz
  2. Update packages list:
    # urpmi.update -a
  3. Install groovy17 rpm package:
    # urpmi groovy17

Files

Path
/etc/maven/fragments/groovy17
/usr/bin/groovy17
/usr/bin/groovyConsole17
/usr/bin/groovyc17
/usr/bin/groovysh17
/usr/bin/java2groovy17
/usr/bin/startGroovy17
/usr/share/groovy17
/usr/share/doc/groovy17-1.7.10/LICENSE.txt
/usr/share/groovy17-1.7.10/groovy
/usr/share/groovy17-1.7.10/groovyConsole
/usr/share/groovy17-1.7.10/groovyc
/usr/share/groovy17-1.7.10/groovysh
/usr/share/groovy17-1.7.10/java2groovy
/usr/share/groovy17-1.7.10/startGroovy
/usr/share/groovy17-1.7.10/conf/groovy-starter.conf
/usr/share/groovy17-1.7.10/embeddable/groovy-all-1.7.10.jar
/usr/share/groovy17-1.7.10/lib/ant-junit.jar
/usr/share/groovy17-1.7.10/lib/ant-launcher.jar
/usr/share/groovy17-1.7.10/lib/ant.jar
/usr/share/groovy17-1.7.10/lib/antlr.jar
/usr/share/groovy17-1.7.10/lib/apache-ivy.jar
/usr/share/groovy17-1.7.10/lib/asm-analysis.jar
/usr/share/groovy17-1.7.10/lib/asm-tree.jar
/usr/share/groovy17-1.7.10/lib/asm-util.jar
/usr/share/groovy17-1.7.10/lib/asm.jar
/usr/share/groovy17-1.7.10/lib/bsf.jar
/usr/share/groovy17-1.7.10/lib/commons-cli.jar
/usr/share/groovy17-1.7.10/lib/commons-logging.jar
/usr/share/groovy17-1.7.10/lib/groovy-1.7.10.jar
/usr/share/groovy17-1.7.10/lib/jline.jar
/usr/share/groovy17-1.7.10/lib/jsp_2_0_api.jar
/usr/share/groovy17-1.7.10/lib/junit.jar
/usr/share/groovy17-1.7.10/lib/mx4j.jar
/usr/share/groovy17-1.7.10/lib/servlet_2_4_api.jar
/usr/share/groovy17-1.7.10/lib/xpp3.jar
/usr/share/groovy17-1.7.10/lib/xstream.jar
/usr/share/java/groovy17-1.7.10.jar
/usr/share/java/groovy17-all-1.7.10.jar
/usr/share/java/groovy17-all.jar
/usr/share/java/groovy17.jar
/usr/share/maven2/poms/JPP-groovy17-all.pom
/usr/share/maven2/poms/JPP-groovy17.pom

Changelog

2011-12-14 - David Walluck <dwalluck@redhat.com> 0:1.7.10-3
- remove Requires: jansi (optional=true)
- BuildRequires: apache-commons-primitives to work around yum issue
2011-06-12 - David Walluck <dwalluck@redhat.com> 0:1.7.10-2
- use ant 1.8
2011-05-02 - David Walluck <dwalluck@redhat.com> 0:1.7.10-1
- 1.7.10
- fix script name
- fix groovy jar name
- add unversioned dir symlink
- BuildRequires: commons-primitives
2011-01-07 - David Walluck <dwalluck@redhat.com> 0:1.7.6-2
- (Build)Requires: jansi
2010-12-16 - David Walluck <dwalluck@redhat.com> 0:1.7.6-1
- release

See Also

Package Description
groovy17-javadoc-1.7.10-3.jpp6.noarch.rpm Javadoc for groovy17
groovy18-1.8.1-1.jpp6.noarch.rpm Groovy scripting language
groovy18-javadoc-1.8.1-1.jpp6.noarch.rpm Javadoc for groovy18
gsbase-2.0.1-2.jpp6.noarch.rpm GSBase
gsbase-javadoc-2.0.1-2.jpp6.noarch.rpm Javadoc for gsbase
gsbase-manual-2.0.1-2.jpp6.noarch.rpm Documents for gsbase
gshell-2.6.2-1.jpp6.noarch.rpm GShell
gshell-javadoc-2.6.2-1.jpp6.noarch.rpm Javadoc for gshell
gshell-repolib-2.6.2-1.jpp6.noarch.rpm Artifacts to be uploaded to a repository library
gson-1.7.2-1.jpp6.noarch.rpm Convert JSON to Java objects and vice-versa
gson-javadoc-1.7.2-1.jpp6.noarch.rpm Javadoc for gson
gson-manual-1.7.2-1.jpp6.noarch.rpm Documents for gson
guava-05-7.jpp6.noarch.rpm Google Core Libraries for Java
guava-javadoc-05-7.jpp6.noarch.rpm Javadoc for guava
guava-libraries-12.0.1-1.jpp6.noarch.rpm Google Core Libraries for Java
Advertisement
Advertisement