ec2-ami-tools.noarch.rpm


Advertisement

Description

ec2-ami-tools - Tools for creating, bundling and uploading AMIs

Property Value
Distribution RPM Universal
Repository Olea all
Package filename ec2-ami-tools.noarch.rpm
Package name ec2-ami-tools
Package version -
Package release -
Package architecture -
Package type rpm
Homepage -
License -
Maintainer -
Download size 168.41 KB
Installed size 667.50 KB
Tools for creating, bundling and uploading AMIs.

Alternatives

Package Version Architecture Repository
ec2-ami-tools - - -

Requires

Name Value
/bin/bash -
/etc/init.d -
/sbin/chkconfig -
curl -
fileutils -
gzip -
openssl -
rsync -
ruby -
tar >= 1.15

Provides

Name Value
config(ec2-ami-tools) = 1.4-0.0
ec2-ami-tools = 1.4.0.0
ec2-ami-tools = 1.4-0.0

Conflicts

Name Value
ec2-ami-tools-nda -

Obsoletes

Name Value
aes-ami-tools -
amiutil -

Download

Type URL
Mirror olea.org
Binary Package ec2-ami-tools.noarch.rpm
Source Package ec2-ami-tools-1.4-0.0.src.rpm

Install Howto

  1. Download latest olea-repo-release rpm from
    http://olea.org/paquetes-rpm/
  2. Install olea-repo-release rpm:
    # rpm -Uvh olea-repo-release*rpm
  3. Install ec2-ami-tools rpm package:
    # yum install ec2-ami-tools

Files

Path
/etc/ec2/amitools/cert-ec2.pem
/etc/ec2/amitools/mappings.csv
/usr/lib/ruby/site_ruby/ec2/platform.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundle_base.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundleimage.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundleimageparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundlemachineparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundlevol.rb
/usr/lib/ruby/site_ruby/ec2/amitools/bundlevolparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/crypto.rb
/usr/lib/ruby/site_ruby/ec2/amitools/decryptmanifest.rb
/usr/lib/ruby/site_ruby/ec2/amitools/defaults.rb
/usr/lib/ruby/site_ruby/ec2/amitools/deletebundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/deletebundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/downloadbundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/downloadbundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/exception.rb
/usr/lib/ruby/site_ruby/ec2/amitools/fileutil.rb
/usr/lib/ruby/site_ruby/ec2/amitools/format.rb
/usr/lib/ruby/site_ruby/ec2/amitools/instance-data.rb
/usr/lib/ruby/site_ruby/ec2/amitools/manifest_wrapper.rb
/usr/lib/ruby/site_ruby/ec2/amitools/manifestv20070829.rb
/usr/lib/ruby/site_ruby/ec2/amitools/manifestv20071010.rb
/usr/lib/ruby/site_ruby/ec2/amitools/manifestv3.rb
/usr/lib/ruby/site_ruby/ec2/amitools/mapids.rb
/usr/lib/ruby/site_ruby/ec2/amitools/migratebundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/migratebundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/migratemanifest.rb
/usr/lib/ruby/site_ruby/ec2/amitools/migratemanifestparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/minimalec2.rb
/usr/lib/ruby/site_ruby/ec2/amitools/parameter_exceptions.rb
/usr/lib/ruby/site_ruby/ec2/amitools/parameters_base.rb
/usr/lib/ruby/site_ruby/ec2/amitools/s3toolparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/showversion.rb
/usr/lib/ruby/site_ruby/ec2/amitools/syschecks.rb
/usr/lib/ruby/site_ruby/ec2/amitools/tool_base.rb
/usr/lib/ruby/site_ruby/ec2/amitools/unbundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/unbundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/uploadbundle.rb
/usr/lib/ruby/site_ruby/ec2/amitools/uploadbundleparameters.rb
/usr/lib/ruby/site_ruby/ec2/amitools/util.rb
/usr/lib/ruby/site_ruby/ec2/amitools/version.rb
/usr/lib/ruby/site_ruby/ec2/amitools/xmlbuilder.rb
/usr/lib/ruby/site_ruby/ec2/amitools/xmlutil.rb
/usr/lib/ruby/site_ruby/ec2/common/curl.rb
/usr/lib/ruby/site_ruby/ec2/common/http.rb
/usr/lib/ruby/site_ruby/ec2/common/s3support.rb
/usr/lib/ruby/site_ruby/ec2/oem/LICENSE.txt
/usr/lib/ruby/site_ruby/ec2/oem/open4.rb
/usr/lib/ruby/site_ruby/ec2/platform/base.rb
/usr/lib/ruby/site_ruby/ec2/platform/current.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris.rb
/usr/lib/ruby/site_ruby/ec2/platform/base/architecture.rb
/usr/lib/ruby/site_ruby/ec2/platform/base/constants.rb
/usr/lib/ruby/site_ruby/ec2/platform/base/pipeline.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/architecture.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/constants.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/fstab.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/identity.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/image.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/mtab.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/pipeline.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/rsync.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/tar.rb
/usr/lib/ruby/site_ruby/ec2/platform/linux/uname.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/architecture.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/constants.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/fstab.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/identity.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/image.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/mtab.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/pipeline.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/rsync.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/tar.rb
/usr/lib/ruby/site_ruby/ec2/platform/solaris/uname.rb
/usr/lib64/ruby/site_ruby/ec2/platform.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundle_base.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundleimage.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundleimageparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundlemachineparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundlevol.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/bundlevolparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/crypto.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/decryptmanifest.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/defaults.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/deletebundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/deletebundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/downloadbundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/downloadbundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/exception.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/fileutil.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/format.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/instance-data.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/manifest_wrapper.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/manifestv20070829.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/manifestv20071010.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/manifestv3.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/mapids.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/migratebundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/migratebundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/migratemanifest.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/migratemanifestparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/minimalec2.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/parameter_exceptions.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/parameters_base.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/s3toolparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/showversion.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/syschecks.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/tool_base.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/unbundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/unbundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/uploadbundle.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/uploadbundleparameters.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/util.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/version.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/xmlbuilder.rb
/usr/lib64/ruby/site_ruby/ec2/amitools/xmlutil.rb
/usr/lib64/ruby/site_ruby/ec2/common/curl.rb
/usr/lib64/ruby/site_ruby/ec2/common/http.rb
/usr/lib64/ruby/site_ruby/ec2/common/s3support.rb
/usr/lib64/ruby/site_ruby/ec2/oem/LICENSE.txt
/usr/lib64/ruby/site_ruby/ec2/oem/open4.rb
/usr/lib64/ruby/site_ruby/ec2/platform/base.rb
/usr/lib64/ruby/site_ruby/ec2/platform/current.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris.rb
/usr/lib64/ruby/site_ruby/ec2/platform/base/architecture.rb
/usr/lib64/ruby/site_ruby/ec2/platform/base/constants.rb
/usr/lib64/ruby/site_ruby/ec2/platform/base/pipeline.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/architecture.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/constants.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/fstab.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/identity.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/image.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/mtab.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/pipeline.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/rsync.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/tar.rb
/usr/lib64/ruby/site_ruby/ec2/platform/linux/uname.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/architecture.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/constants.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/fstab.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/identity.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/image.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/mtab.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/pipeline.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/rsync.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/tar.rb
/usr/lib64/ruby/site_ruby/ec2/platform/solaris/uname.rb
/usr/local/bin/amitoolsversion
/usr/local/bin/bundleimage
/usr/local/bin/bundlevol
/usr/local/bin/deletebundle
/usr/local/bin/downloadbundle
/usr/local/bin/ec2-ami-tools-version
/usr/local/bin/ec2-bundle-image
/usr/local/bin/ec2-bundle-vol
/usr/local/bin/ec2-delete-bundle
/usr/local/bin/ec2-download-bundle
/usr/local/bin/ec2-migrate-bundle
/usr/local/bin/ec2-migrate-manifest
/usr/local/bin/ec2-unbundle
/usr/local/bin/ec2-upload-bundle
/usr/local/bin/migratebundle
/usr/local/bin/migratemanifest
/usr/local/bin/unbundle
/usr/local/bin/uploadbundle
/usr/local/ec2/amitools/amitoolsversion
/usr/local/ec2/amitools/bundleimage
/usr/local/ec2/amitools/bundlevol
/usr/local/ec2/amitools/deletebundle
/usr/local/ec2/amitools/downloadbundle
/usr/local/ec2/amitools/migratebundle
/usr/local/ec2/amitools/migratemanifest
/usr/local/ec2/amitools/unbundle
/usr/local/ec2/amitools/uploadbundle
/usr/local/share/doc/ec2-ami-tools/license.txt
/usr/local/share/doc/ec2-ami-tools/notice.txt

Changelog

2005-11-10 - James Greenfield <jamesg@amazon.com> 1.4.1rh-30
- Describe the magic you worked here.

See Also

Package Description
ec2-api-tools-1.4.4.1-1.olea.noarch.rpm Amazon EC2 Command-Line Tools
ejabberd-2.0.4-1.i386.rpm A distributed, fault-tolerant Jabber/XMPP server
ejabberd-2.0.5-2.i386.rpm A distributed, fault-tolerant Jabber/XMPP server
ejabberd-2.0.5-3.i386.rpm A distributed, fault-tolerant Jabber/XMPP server
ejabberd-doc-2.0.4-1.i386.rpm Documentation for ejabberd
ejabberd-doc-2.0.5-2.i386.rpm Documentation for ejabberd
ejabberd-doc-2.0.5-3.i386.rpm Documentation for ejabberd
evince-0.4.0-1.2.i386.rpm Document viewer
evolution-webcal-2.7.1-6.i386.rpm A handler for webcal URIs
exslt-0.0.1-20031014.3olea.noarch.rpm Extensions for XSLT
ezV24_0-0.1.1-1mdk.i386.rpm Dynamic libraries from ezV24
ezV24_0-devel-0.1.1-1mdk.i386.rpm Header files and static libraries from ezV24
fake-1.0-0.noarch.rpm Fake RPM
fedOne-0.2-1.r96hg.fc11.noarch.rpm Google Wave Federation Prototype Server
fedora-packager-0.1.1-1olea.noarch.rpm Tools for setting up a fedora maintainer environment
Advertisement
Advertisement